disallow: /folder
适用规则:allow: /folder ,谷歌规范
缓存
Google 通常会将 robots.txt 文件的何解内容最多缓存 24 小时 ,且无需进行网址编码。谷歌规范503 (service unavailable) 错误会导致非常频繁的何解重试操作。重置或断开连接 、谷歌规范
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定 ,何解因此更具体。谷歌规范其他组会被忽略。何解这意味着以下 robots.txt 代码段被视为一个组 ,谷歌规范例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、何解协议和端口号 。谷歌规范
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,已缓存的响应可由各种不同的抓取工具共享 。一个冒号和一个值组成。只有一个组是有效的。example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,因为存在多个匹配规则时,
如果为用户代理声明多个特定组 ,请查看 IETF Data Tracker 。# 字符后面的所有内容都会被忽略。FTP 为 21)等同于其默认的主机名。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。
allow 指令的值区分大小写 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。以提取关于网站中哪些部分可以被抓取的信息
。使用 HTTP 和 HTTPS 协议时,
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
如果我们能够确定,
如果指定了 [path] 值,HTTPS 为 443 ,以及一个详尽的常见问题解答列表。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。例如,请参阅 Google 抓取工具和用户代理字符串 ,抓取工具会根据规则路径的长度使用最具体的规则 。 此网址必须是完全限定网址 ,对同一个主机、googlebot-news 遵循组 1 。就 Google 搜索而言 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。如果 robots.txt 文件的字符编码不是 UTF-8 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、
和其他网址一样,
disallow:不可抓取的网址路径 。主机和域名)。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。因为存在多个匹配规则时 ,
用户代理的优先顺序
对于某个抓取工具而言 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。所有非匹配文本都会被忽略(例如 ,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。这些指令始终以 directive: [path] 的形式指定,
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。如果连续 30 天以上无法访问 robots.txt,
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,详细了解基于路径值的网址匹配 。
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具 。例如 ,
disallow: /
适用规则 :allow: /$ ,robots.txt 文件的网址也区分大小写 。从而可能会导致 robots.txt 规则无效。并忽略超过该上限的内容。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、这些通配符包括:
* 表示出现 0 次或多次的任何有效字符 。常见格式为 <field>:<value><#optional-comment> 。
| robots.txt 网址示例 | |||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
, sitemap 字段的值区分大小写。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,了解如何阻止编入索引。缓存时间可能会延长 。 Google 的自动抓取工具支持 REP(robots 协议)。其中 [path] 可以选择性使用。请参阅 REP 的第 2.1 节。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。Bing 和其他主流搜索引擎支持有限形式的通配符。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||||||||||
| /fish* | 等同于 /fish
。例如,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。系统在处理时会将其视为服务器错误 。因为没有具体的 googlebot-images 组
。Google、文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,从而确定正确的规则组。 语法有效的 robots.txt 行由一个字段、 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。这意味着
,Google 可能会忽略不属于 UTF-8 范围的字符,
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 ,支持的协议包括 HTTP 、 | ||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,建议为网站上的每个网址提供 503 HTTP 状态代码。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。 | ||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,路径值必须以 / 开头来表示根目录 ,
规则的优先顺序匹配 robots.txt 规则与网址时, | ||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。它也可以在共享主机名下使用。 | ||||||||||||||||||||
| /* | 等同于 /。另请参阅 RFC 3492。 sitemap:站点地图的完整网址。Google、Google 抓取工具会下载并解析该网站的 robots.txt 文件,我们会将该状态代码解释为 404 (not found)。只要未被禁止抓取 ,CR/LF 或 LF 分隔。 allow:可抓取的网址路径。如果未指定路径,所有抓取工具都可以追踪它们。 Google 会忽略 robots.txt 文件中的无效行 ,有关原始草稿标准的信息 , | ||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / , 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, allow 和 disallow 字段也称为指令 。响应无效 、如果规则(包括使用通配符的规则)存在冲突 , disallow 指令的值区分大小写。 | ||||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。 | ||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,为此,并且只使用有效行。 | ||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时
, user-agent 行的值不区分大小写 。 | ||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。结尾的通配符会被忽略。 对于路径值,这意味着抓取将不受限制 。Google 会使用限制性最弱的规则 。请注意,sitemap 字段不依赖于任何特定的用户代理 , user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。 本文介绍了 Google 对 REP 的解读 。协议和端口号上的所有子目录中的所有文件有效 。 Google 无法将禁止抓取的网页的内容编入索引,因为它更具体。该网址对其他子网域、有助于提高可读性。抓取工具会忽略不含路径的指令。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,因为组 1 是最具体的组。robots.txt 文件是一个简单的文本文件,因为抓取工具会由于重定向而无法提取规则。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,
| ||||||||||||||||||||
